Is your Sitecore 8 package installer goes in never ending loop?

Friends – Have you started your Sitecore 8 Journey? How’s it? It’s awesome.. right? You will observe many new things while exploring Sitecore 8. This post will talk about one of such things. Scenario: If you find that your Sitecore 8 package installer is going in never ending loop, then this post may help you.

Reason: If you look at your logs during package installation, then you may find few errors reported by Sitecore.Analytics.MongoDB. This tells that your Sitecore 8 instance is not able to connect with your Mongo DB. Solution: Well, solution is very simple. You need to start your MongoDB database process by firing below command:

mongod.exe --dbpath "[location of your MongoDB/data/db]"
For example:
mongod.exe --dbpath "C:Program FilesMongoDB 2.6 Standarddatadb"

In case, if you haven’t installed/configured MongoDB for your Sitecore 8 then you need to first setup MongoDB and then start MongoDB database process. If you are looking for how to setup MongoDB then this link may help you. After staring MongoDB database process, now try to install package in your Sitecore 8 instance and it should get installed without any issue.

11 Responses to “Is your Sitecore 8 package installer goes in never ending loop?”
  1. The Belly Boy March 1, 2015
  2. Nilesh Thakkar March 2, 2015
  3. Unknown July 21, 2015
  4. Nilesh Thakkar July 21, 2015
  5. Unknown July 23, 2015
  6. Unknown July 23, 2015
  7. Unknown July 28, 2015
  8. Nilesh Thakkar July 28, 2015
  9. Unknown October 3, 2015
  10. Nilesh Thakkar October 3, 2015
  11. Venkata Phani Abburi February 22, 2016

Leave a Reply

Hello, Sitecore Hero!
We've got a fresh look, welcome to new Sitecore Journey.
+